Action Required: Your app is not compliant with Google Play Policies

Boa tarde colegas.
Tudo bom?

Hoje fui atualizar o app na loja e recebi uma mensagem do Google. Me parece ser algo simples, mas não consegui localizar qual informações atualizar. Muito obrigado pelo retorno e segue o e-mail:

Status: Aprovado com problemas - Ação adicional necessária

Encontramos problemas com seu aplicativo. Você precisa revisar e agir conforme descrito abaixo, para que seu aplicativo não seja afetado no futuro.

### Problema encontrado: seção de segurança de dados inválida

Analisamos a seção Segurança de dados do seu app no ​​Play Console e encontramos discrepâncias entre ela e como o app coleta e compartilha dados do usuário. Todos os aplicativos precisam preencher uma seção de segurança de dados precisa que divulgue suas práticas de coleta e compartilhamento de dados - esse é um requisito mesmo que seu aplicativo não colete dados do usuário.

Detectamos dados do usuário transmitidos do dispositivo que você não divulgou na seção Segurança de dados do seu aplicativo como dados do usuário coletados.

Detalhes do problema

Encontramos um problema nas seguintes áreas:

  • SPLIT_BUNDLE 120000: Declaração de política - Seção de segurança de dados : Dispositivo ou outros IDs Tipo de dados - Dispositivo ou outros IDs (alguns exemplos comuns podem incluir ID de publicidade, ID do Android, IMEI, BSSID)

Sobre a seção Segurança de dados na Política de dados do usuário do Google Play

A partir do final de abril de 2022 , as seções de segurança de dados aprovadas começarão a aparecer para os usuários; fazer as alterações necessárias até então. A partir de 20 de julho de 2022 , seu aplicativo deve estar em conformidade com esta política ou as atualizações do aplicativo serão rejeitadas. Se seu aplicativo continuar incompatível após 20 de julho de 2022, ele poderá enfrentar ações de fiscalização adicionais no futuro.

Faça alterações para alinhar a seção de segurança de dados do seu aplicativo com o comportamento do aplicativo. Isso pode ser feito por:

  • Atualizar seu formulário no Play Console para declarar a coleta de tipos de dados indicados abaixo; ou
  • Remoção de funcionalidade indesejada e código atribuível que coleta esses dados do usuário do seu aplicativo ou das bibliotecas usadas no seu aplicativo e, quando aplicável, para desativar todos os APKs não compatíveis.
    • Para desativar os APKs não compatíveis, você pode criar uma nova versão e fazer upload de um APK compatível para cada faixa que contém os APKs não compatíveis.
    • Certifique-se de incrementar o código da versão do APK. Se estiver usando o lançamento gradual, certifique-se de definir o lançamento para 100% de lançamento.

Coloquei um app na loja , deu esse mesmo problema com número diferente do split bundle, to curioso pra saber.

Seu aplicativo coleta dados do dispostivo e necessário informar isso no formulário Segurança de Dados

Boa tarde, tudo bem?

Isso mesmo! Você pode seguir este artigo para informar ao Google todos os dados que seu app coleta, inclusive como seu app lida com dados (exemplo: E-mail → Coletado para login)

Qualquer coisa estamos à disposição

preenchi várias vezes, ele aprovou com erros, deixei assim mesmo.

Boa tarde Marcio, tudo bem?

Certo, fico feliz que tenha sido aprovado! Mas se os erros forem sobre a coleta de dados, peço que verifique se marcou “Identificadores do dispositivo e outros”, como está na imagem abaixo:

Este dado é coletado por todos os apps da Fabapp, e você precisa marcar também, para que não apareçam mais erros sobre a coleta de dados.
Se tiver mais dúvidas, é só chamar :wink: